Sony W805C - List of bugs

Since receiving this TV a couple of months back I have experienced a number of issues with the Android OS. Going by the discussion on various forums, it seems I am not the only one...

There are missing features - features promised to be here by now and no sign of yet. There are also lots of software defects, some minor and some major. Some are intermittent, some persistent. I thought I should compile a list as a useful reference, and tick them off as and when they are fixed. So, here we go.

Update 2nd October 2015: the items shown in green are those reported by others.

Important missing features

There are quite a few promised features missing and the dates have been continually pushed back. Here are the main ones that I care about:

  • YouView - yes the obvious one, this has been continually pushed back. At time of writing (26th September) Sony's own FAQ item still says "summer 2015". Well, summer's gone Sony...
  • USB recording. I asked Sony support about this one back in the beginning of July, as trying to record gives an "update required" message. Again this has been pushed back, from August to "sometime this year". That is utterly ridiculous - by that time, the TV will be a fraction of the price. To top it off, Sony have revealed that YouView and recording features will be mutually exclusive. That is, if you install YouView you will lose access to the USB recording (and satellite viewing) features entirely.

Permanent defects

  • The Netflix, Amazon and Plex apps are unable to pass through mutichannel audio to a connected amplifier - either through HDMI or optical. I am told this is because Sony have not implemented the relevant support in Android.
  • The video player does not support subtitles properly. It plays normal subtitles (rather than just forced subtitles) by default, and they cannot be turned off. The menu items exist, but using them has no effect, except that the overlay is stuck on screen whilst the video plays. I have tested this for MKV/H264 content, not sure about anything else as this is all I use subtitles for.
  • The video player plays DVD-sourced content (MKV/MPEG2) content in the wrong aspect ratio
  • The video player has no aspect ratio controls.
  • Apps do not switch the TV's refresh rate according to the content type (e.g. 25p or 24p content). I am told this is because Sony have not enabled the required connection from Android to their core firmware.
  • There is a significant and very distracting delay in audio passed through to an amp. This applies both to HDMI-connected sources and TV apps. Seems to be mainly Dolby/DTS.
  • The TV doesn't turn on with certain CEC devices turn on, though they work with other TVs.
  • The TV doesn't switch to the correct input when CEC devices turn on
  • After power-on from standby, the TV does not respond properly to input-change requests from the remote (I use Harmony)
  • The Advanced Contrast Enhancer causes significant, sudden and very distracting brightness changes (even when the scene doesn't change). It doesn't seem possible to turn this down.
  • 1080p 3D BluRays display with reduced detail (resolution)
  • The TV responsiveness slows down over time, as apps are not closed
  • I am on wired ethernet. The network settings icon has an exlamation mark next to it, despite the diagnostics reporting a working connection.
  • Playing content to the TV (i.e. the DLNA renderer function) usually fails with a "cannot be played" error message - this is for content that the TV documentation says it supports, and that works (with caveats above) when accessing through the TV's own Videos app. This seem to have stopped happening (fixed in a previous ipdate?), but content played this way uses the Videos app, so still has the same problems as above.
  • No documentation appears to exist for which button does what in the core apps of the TV. Apps seem barely function. e.g. how do you page up or fown in EPG? I cofound out by random presses that two of the colours buttons do 24h+/-

Intermittent defects

  • The TV occasionally sponteneously reboots
  • Core processes in the Android OS crash, giving error messages like "TVService stopped responding". The effects are variable, usually requiring a reboot.
  • The TV occasionally fails to turn on until the power cable is disconnected
  • Watching content from my HDMI-connected WDTV live, the volume control appears on the control intermittently, of its own accord. This happens roughly every 10 minutes.
  • Watching a BluRay from my HDMI-connected PS3, occasionally there is no sound, or the sound switches back and forth between 5.1 AC3 and stereo PCM.
  • The TV occasionally turns on of its own accord
  • The TV occasionally gets confused about what input it is on (i.e. selecting the input doesn't activate it)
  • The picture settings menu randomly disappears when you're trying to change a setting
  • Sometimes the picture settings menu fails to appear
  • The action menu can sometimes be very slow
  • Sometimes recommendations fail to appear
  • Sometimes the Netflix button gives a "network not connected" message, but the (wired) network connection is fine.
  • YouTube sometimes plays videos extremely juddery with an audio delay of several seconds. This seems to have stopped happening.
  • BBC iPlayer freezes and requries a hard reboot to work again
  • Apps such as iPlayer cannot be launched (error message shown), workaround is to hard reboot

Third party apps

  • The Archos app hangs when attempting to access SMB folders my DLNA server
  • The Emby client app seems to want to transcode absolutely everything. I had to actually purchase the app to find this out, as videos don't play otherwise. It also only allows you to specify upto 30Mbps maximum, which is likely to be exceeded for Blu Ray rips.
  • The VLC app has occasional issues seeing content when accessing DLNA servers, and has no SMB or NFS capability.
  • Kodi lacks key mappings for important remote buttons and Kodi functions (like context menu).
  • Kodi fails to play VC1 content.

Tags:

Comments

* Intermittent defects : BBC Iplayer freezes and requries a hard reboot to work again

* Intermittent defects : Apps such as iplayer cannot be launched (error message shown), workaround is to hard reboot

* No documentation appears to exist for which button does what in the core apps of the TV. Apps seem barely function. e.g. how do you page up or fown in EPG? I cofound out by random presses that two of the colours buttons do 24h+/-

 

 

Skype is not supported.

Noted, although it would be unfair to call this a bug and as far as I am aware it has never been listed as a feature.

I recently purchased the W805c (February 2016).
The problem with the amp remains. The TV is still slow to pass sound to it. It can take several seconds to work through optical. Over half an hour through HDMI. I wanted HDMI to work, so that I could use Bravia Sync and control my amp with the Sony remote. It wasn't to be. Very annoying. Another 'feature' this TV has is its slow responsiveness. It's slow to load menus, and as you have experienced, it slows down over time. YouView is here, and it's much better than the stock Freeview guide, but it isn't perfect. It too is slow. Regardless, this TV has an exceptional picture, and I won't be sending it back. I just hope Sony get around to making it a little snappier.

Add new comment

(If you're a human, don't change the following field)
Your first name.
(If you're a human, don't change the following field)
Your first name.
(If you're a human, don't change the following field)
Your first name.

Normal input

  • Allowed HTML tags: <div> <span> <a> <em> <strong> <b> <i> <cite> <blockquote> <code> <pre> <ul> <ol> <li> <dl> <dt> <dd> <img> <div> <p> <br> <h1> <h2> <h3> <h4> <h5> <h6> <table> <tr> <td> <th> <thead> <tfoot> <hr>

Plain text

  • No HTML tags allowed.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Lines and paragraphs break automatically.